1. By continuing to use the site, you agree to the use of cookies .This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the cookie policy.Find out more.
    Dismiss Notice
  2. Follow Casinomeister on Twitter | Facebook | YouTube | Casinomeister.us US Residents Click here! |  Svenska Svenska | 
Dismiss Notice
REGISTER NOW!! Why? Because you can't do diddly squat without having been registered!

At the moment you have limited access to view most discussions: you can't make contact with thousands of fellow players, affiliates, casino reps, and all sorts of other riff-raff.

Registration is fast, simple and absolutely free so please, join Casinomeister here!

Thunderbird 31.0 update: Proceed With Caution!

Discussion in 'Computers and Internet Geekland' started by maxd, Jul 23, 2014.

    Jul 23, 2014
  1. maxd

    maxd Complaints (PAB) Manager Staff Member

    Occupation:
    The PAB Guy
    Location:
    Saltirelandia
    Heads-up to all you Thunderbird users out there: using the recent update to 31.0 may COMPLETELY OBLITERATE the contents of your email folders. As in you may have had hundreds -- or in my case, many thousands -- of emails in your folders before the update but afterwards your folders will be nice and empty. That's a feature, no? Fetching new email works as expected.

    FWIW I'm on Linux Mint 17. It seems I was "upgrading" from v24.4.0 to 31.0.0 when the impromptu house-cleaning happened.

    I've uninstalled, restored my Thunderbird profile from backup and tried again with the same result: empty folders.

    I'm now investigating the options for reverting to a previous version. Fingers crossed.

    I've confirmed that this has happened to other users going back as far as v24.0 last September. Seems it's an intermittent thing and so far I haven't found a proper analysis and solution of the problem.
     
    2 people like this.
  2. Jul 23, 2014
  3. Azzurri

    Azzurri Banned User

    Occupation:
    Non of your business
    Location:
    From Foil Land
    Thanks for the heads up, but I'm just a Thunderbirds watcher. :D
     
  4. Jul 23, 2014
  5. Tirilej

    Tirilej Still a Lady CAG MM

    Occupation:
    Breathing
    Location:
    Sweden
    How horrible:eek2:
    I have emails from over 11 years saved. What if I lost them?

    Is all Pab's and stuff also in there, and contacts lost too?
     
  6. Jul 23, 2014
  7. maxd

    maxd Complaints (PAB) Manager Staff Member

    Occupation:
    The PAB Guy
    Location:
    Saltirelandia
    Nothing lost, I have multiple backups, just the PITA of having to deal with this update snafu.
     
    1 person likes this.
  8. Jul 24, 2014
  9. maxd

    maxd Complaints (PAB) Manager Staff Member

    Occupation:
    The PAB Guy
    Location:
    Saltirelandia
    Well! That was fun .. not! Back in business though. Turns out TBv31.0 may only be partially to blame for this big old mess.

    I've been migrating off of our laptop onto my nice shiny new computer. The TB I had been using on the laptop before I moved over to the new box was v24.6.0 and it seemed to have been running fine on the new box.

    At some point I backed up my TB files on the new box and a day or so later upgraded to TBv31.0. Boom! 99.9% of my emails were toast, only stuff from the last few days was listed. Deleted my TB profile and restored from the local backup. Same results: emails borked.

    Looked at the raw email files in the backup. They seemed fine, all the old emails were there.

    Did a bunch of web searching for info on how to fix this screwed-up situation, read that if you deleted the index files -- *.msf -- then TB will rebuild them and in the process (possibly) fix things. Deleted those files.

    Fired up TB and success! The old emails were there just as they should be .. for about 10 seconds. I'd be looking at the list of email in a sub-folder and they'd simply disappear before my eyes, quite literally. Suddenly no emails in that folder. :eek2: Navigate away and come back, empty folder! Looked at the raw email files and sure enough, all gone.

    Rolled back to a previous version of TB, restored the profile, fired it up: no joy. Same crap: missing emails.

    Eventually I abandoned the backup and went back to TB on the laptap. Everything was there and looking good. Did a copy of that profile, moved it over to the new box. Ripped out the previous version of TB that I'd installed and updated to the new version. Copied the fresh profile backup over and started TB: happy days! All there and accounted for. Quit and restarted, still good. So now, finally, the new TB was up and running with the old email.

    I have no clue what actually caused this in the first place but it seems that the original backup I'd done had introduced or captured a borked profile: no amount of restoring that profile changed the fact that it was hooped. Why the problem hadn't manifested in the previous TB version is anybody's guess, but something in the process of updating to the new version simply reacted to the bork and showed the results.

    Anyway, all's well I guess. Lost the better part of a day's effort but now up and running with the new TB and all my old emails. :thumbsup:
     

Share This Page