Bonus Complaint System error dispute with 7regal

onkel

New Member
PABnonaccred
Joined
Jan 22, 2013
Location
Larnaca, Cyprus, Cyprus
Hi all,

I'm a new member here at CM who is hoping to get some help regarding a dispute with online casino 7regal. The dispute stems from a system error that caused me to redeposit because of a 0 balance, while the casino says there were funds left and forces me to continue wagering towards my first deposit bonus.

The story is a bit long and I apologize beforehand for my poor grasp of English.

The dispute:

Yesterday I decided to have a go at some gambling and chose to create an account with the Playtech casino 7regal. Upon signing up with 7regal one is offered a 300% playable bonus. The max bonus is 2000sek (the currency I'm playing with), so to make use of the full bonus I deposited 750sek.

All went fine besides a little problem getting the full bonus that was easily resolved via support. Unfortunately I went on to lose the full amount rather quickly, and with 12.50 left I adjusted my last bet to 12.50 (was previously betting 15/18.75/22.50 per spin) so there wouldn't be a cent left in my account for my next deposit. My balance was now showing 0.00.

I then deposited another 750sek and declined the 2nd deposit bonus and headed over to roulette, which is something I never would do with a bonus given the trouble it can get one into. The following several hours went up and down playing numerous different games until I eventually hit a hot streak and got up to 5078.50.

I now wanted to withdraw some of my winnings but was immediately hit by the software telling me that I cannot withdraw because I currently have a bonus. Obviously most casino software reset the bonus when you drop down to zero so I immediately contacted support about what was going on. I was then told that the first deposit bonus was still active as I had 74.25sek left when I redeposited - which I couldn't understand as it was showing 0.00 when I did just that, and I had 750 when I started playing roulette.

I went back and forth with the support person for a long while until we discovered that the numbers I saw in my balance weren't the ones being recorded in the history - there was a constant 74.25 discrepancy. I took a screenshot of this:

screenshot.jpg

The screenshot shows my balance in the bottom less 18.75 which is what the bet is set to in the slot game I have open the game history for - and suprise, 5152.75 - (5059.75+18.75) = 74.25.

I kept telling the support person that I would never EVER redeposit with remaining funds in my account as the bonuses are not cashable, so a redeposit of 750sek would put me in a 2000sek hole and with 30k left of the wagering requirement at that. She was very understanding and said she would include that in her report to the people who were going to look at it.

So fast forward to today, instead of removing the bonus requirements and leaving my balance intact, my account has now been adjusted to 5152.50 (the top number in the screenshot), and I'm sitting with loads left of the wagering requirement as well bonuses that will be deducted when I'm finished.

On the phone with a manager earlier today I kept saying that there is no way these 74.25 was visible on my side, but how could I now prove it besides the screenshot I've given them. He kept going on about how many players they have and how some don't know what they're doing and how it couldn't be possible I didn't notice the 74.25 when I redeposited (or at any time after that).

If you take a look at the screenshots below, every single roulette spin was spun with a balance ending with the numbers 4.xx (even between sessions) and basically every time I switched games the ending balance shows as "2774.50" 1575.50" "3274.25" and so on - and the reason for this is simply that I was switching games on even hundreds or when I couldn't make another spin at the stakes I was playing without breaking another hundred. I have no secret love about stopping on even hundreds + 74.25 :)

Screenshot 2: Great Blue
Shows that I adjusted my bet to 12.50 before leaving (and this was to clear my balance), just before I went on to make my second deposit. The spin over it is from the next session, just after I won 740 in roulette

bluestart.jpg

Screenshot 3: Roulette
My first spin after my redeposit (my balance was showing 750 here, but as you can see, the game history doesn't)

roulettefirst.png

Screenshot 4: Roulette
Some more roulette, I'm playing spins with even 10's, so why would I keep switching games with a balance ending with xx4.xx

roulette3.png

Screenshot 5: Penguin Vacation
I ended a session when I couldn't make another bet without breaking a hundred - the following session starts on an even hundred

peng1.jpg

* Could only attach 5 files to one post, please see next post for more screens

Screenshot 6: Penguin Vacation
And again

Screenshot 7: Captain's treasure
And again

Screenshot 8: Great Blue
And again

So these screens are basically all I have to prove there was a system error and that I was while playing (and after) shown an amount 74.25 less than the amount recorded in the game history. Obviously this is not how it's looking on 7regal's end, as they are only going by the game history which clearly has another amount. I am relying on them to believe what I'm saying and also to understand that I would never redeposit before clearing my account as it costs thousands in EV to do so.

Do you guys think there is any chance of getting them to drop the wagering reqs and let me keep my money?

* Full disclosure: there are a couple of games I've jumped between when not having even hundreds, but those are far less and only after I've almost instantly won in the new game and the jumped back to the old.
 

onkel

New Member
PABnonaccred
Joined
Jan 22, 2013
Location
Larnaca, Cyprus, Cyprus
To be clear(er) - to me the balance was always showing 74.25 less than the amount in the game history, so the sessions in the three screenshots above started and ended on even hundreds. What 7regal is claiming is that all my sessions started and stopped with the balances shown above and I was seeing this the whole time.
 

vinylweatherman

You type well loads
Joined
Oct 14, 2004
Location
United Kingdom
To be clear(er) - to me the balance was always showing 74.25 less than the amount in the game history, so the sessions in the three screenshots above started and ended on even hundreds. What 7regal is claiming is that all my sessions started and stopped with the balances shown above and I was seeing this the whole time.

They will screw you over rather than admit the existence of what is clearly a SERIOUS tracking error of a players' balance.

Can you PAB for this casino?

Such issues have cropped up in the past for different softwares, and it is very hard to force operators to take the matter seriously as doing so means admitting to a fundamental flaw in their software.

MGS is particularly prone to the error of carrying over a WR after a player reaches zero. A much more detailed examination of the play history is needed to see what action triggered this balance error, which seemed to persist even when you changed game. It implies that the error was at the server end, as changing game should have refreshed all the data being displayed, and if the balance error was merely at the client end, changing game should have corrected it.

Did you ever make a bet for the exact amount of the error, or have a win for this same amount?

These would be the two incidents to look for in the game history as the most likely starting point for this tracking error.
 
Top