Some games not loading

9HOURSAWAY

Experienced Member
PABnononaccred
Joined
Aug 3, 2018
Location
Nottingham
Hi All

I joined Unibet this week as they have a great selection of slots but I've had a few issues with quite a lot of games refusing to load.

Basically whenever I tried to open games from Wms, BTG (but strangely not Final Countdown) and some other providers whose name escapes me it opens to a black screen where the slot should be and then gives me a message with words to the effect that 'blah blah Malta took too long to respond'

Play n Go, Netent and Push gaming all worked fine with no issues.

I should say that this problem only occurs on my desktop pc running chrome on Windows 7, I tried clearing the cache, but that made no difference.

On my Android tablet again running chrome, every game from all suppliers load and play fine.

Might this be a problem at my end, and if so any ideas how I can fix it, or is it something the providers need to sort out?

Thanks in advance for any advice
 

danofthewibble

Senior Member
Joined
Jan 2, 2018
Location
UK
It's possible an ad-blocker or similar may be stopping them loading. I've had issues as well.

Try using in a browser with no extensions.
 

snorky510238

Chief glockenspiel maker
Joined
Jan 12, 2018
Location
Uk
I play on a mobile and have had issues at Unibet and VS especially with BTG and Thunderkick games. It is their issue as I have played Bonanza on a different platform and it plays fine. As mentioned above it seems to be the NYX server based games.
 
Top