1. By continuing to use the site, you agree to the use of cookies .This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the cookie policy.Find out more.
    Dismiss Notice
  2. Follow Casinomeister on Twitter | Facebook | YouTube | Casinomeister.us US Residents Click here! |  Svenska Svenska | 
Dismiss Notice
REGISTER NOW!! Why? Because you can't do diddly squat without having been registered!

At the moment you have limited access to view most discussions: you can't make contact with thousands of fellow players, affiliates, casino reps, and all sorts of other riff-raff.

Registration is fast, simple and absolutely free so please, join Casinomeister here!

lack of security

Discussion in 'Payment Processing Issues' started by rainmaker, Mar 2, 2011.

    Mar 2, 2011
  1. rainmaker

    rainmaker I'm not a penguin CAG webmeister

    Occupation:
    -
    Location:
    -
    I usually use my credit card to deposit into my casino accounts. But I wanted to try a new casino last night and my credit card was declined (it happens sometimes when using Norwegian cards to gamble).

    I saw that the casino accepted "Entropay" (virtual Visa card). So I thought I could try my virtual Entrocard. I signed up at Entropay for about a year ago, but it has been 8-9 months since I used it last time.

    I visited Entropay.com, but did not remember my username or password. So I sent a mail to CS and asked them what I could do to re-open my account.

    I got a reply with 7 questions that I needed to answer (full name, username etc..) before they would re-open my account. Well, I only managed to answer 3 out of the 7 questions. To my surprise they re-opened my account.

    So I logged inn. There I had to re-activate the account before I could use it. But I did not manage to re-activate it because I did not remember the answer to my "secret question" :oops: and the last 4 digits of my credit card that I used when I registered (old credit card, don't have it anymore). I did send a new mail to CS and asked them what to do. They replied "we have now re-activated your account".

    This seems like a deficient security system in my opinion.
     

Share This Page