1. By continuing to use the site, you agree to the use of cookies .This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the cookie policy.Find out more.
    Dismiss Notice
  2. Follow Casinomeister on Twitter | Facebook | YouTube | Casinomeister.us US Residents Click here! |  Svenska Svenska | 
Dismiss Notice
REGISTER NOW!! Why? Because you can't do diddly squat without having been registered!

At the moment you have limited access to view most discussions: you can't make contact with thousands of fellow players, affiliates, casino reps, and all sorts of other riff-raff.

Registration is fast, simple and absolutely free so please, join Casinomeister here!

Huge delay/lag clicking coin size/play etc. with Avalon at GUTS - anyone else?

Discussion in 'Online Casinos' started by Jakestar, Dec 18, 2014.

    Dec 18, 2014
  1. Jakestar

    Jakestar Senior Member

    Occupation:
    Aircraft Pushback Driver
    Location:
    Australia
    Hi all,
    After a pretty bad run today at GUTS after taking the Christmas 100% bonus (first time claiming a deposit bonus at Guts) and then depositing a few more times, decided to play my last $10 for the day (Ukash sitting in my wallet) and thought - let's try something different and give the original Avalon a go. Planned on just playing $0.40 a spin till $5 and then would switch down to $0.20 if my balance got to that. Well straight away set it to 0.01 denom and clicked coin size till it was 2 for $0.40 and hit spin which was super laggy delayed and took a good 3 seconds before changing to 1 then 2 etc. coin size. So hit spin, saw that it was 0.40 as I wanted, then next spin it went up to 0.80, and before I could stop it it would keep spinning and went to $1.40 then $1.80 I think and then finally stopped. (as I tend to click spin rapidly when it's spinning out of habit/twitch etc. - and it appears that becuase of the delay it read the coin size changes and spins greatly after I actually clicked them which was only cos it was delayed.) Anyway, wasn't too happy as I was trying to play conservative being my last deposit for the day, and once I rectified and carefully made sure it was set to 2 coins 0.40, I played till now $3 - change to 0.20 and ultimately finish at $0 (after bailing out on my last 80 cents to try and save my balance on deuces wild but to no luck :( ) anyway, just getting it out of my system and to warn anyone about this delay in button input if it isn't just a issue at my end of course - but my laptop is decently specced and all other games play flawlessly (Immortal romance, gonzo's quest etc.) anyhoo, I'll stop rambling now, this is out of character for me and usually stuff like this doesn't get to me, I guess it was just todays bad run and then this happening on my last tener heh ^_^
     
  2. Dec 18, 2014
  3. Mosse

    Mosse Experienced Member

    Occupation:
    government
    Location:
    finnlandia
    i have exact the same delay on Avalon.

    but for me it is on every casino. have been wondering pretty long that why there is this problem. i think it started somewhere last summer.

    very odd...
     
    1 person likes this.
  4. Dec 18, 2014
  5. me_and_ed

    me_and_ed Ueber Meister CAG MM

    Occupation:
    Selling out
    Location:
    Vancouver
    Every Quickfire I have played at has the same issue with Avalon as well.
     
    1 person likes this.

Share This Page