Anyone play at Jackpot City?

chayton

aka LooHoo
webmeister
PABnonaccred
CAG
Joined
Jun 5, 2006
Location
Edmonton Canada
I played the day before yesterday and the casino was soooo slow - every second spin on the slots was 15 seconds (or longer) of the spin animation. I exited, restarted, rebooted, cleared my cache, dumped my temp files, tried everything. All the other MG casinos work fine, even River Belle who's in the same group. I sent them a mail and they did their standard "oh nothing wrong here - must be your computer....time of day, etc etc" But I just cashed in some comps and tried again and it's still really sluggish. I'm wondering if anyone else could check and let me know if they have the same problem? Then I'll know if it's the casino or if it's just me. Thanks!
 

De Beuker

Senior Member
Joined
Apr 20, 2009
Location
Netherlands
I played the day before yesterday and the casino was soooo slow - every second spin on the slots was 15 seconds (or longer) of the spin animation. I exited, restarted, rebooted, cleared my cache, dumped my temp files, tried everything. All the other MG casinos work fine, even River Belle who's in the same group. I sent them a mail and they did their standard "oh nothing wrong here - must be your computer....time of day, etc etc" But I just cashed in some comps and tried again and it's still really sluggish. I'm wondering if anyone else could check and let me know if they have the same problem? Then I'll know if it's the casino or if it's just me. Thanks!

Exactly the same problems as you describe, its the main reason I hardly play there anymore, it used to be one of my favourites.
Tried last week with a small deposit after a month of not playing there, and nothing had changed.:mad:
As you say, it takes many seconds before the first reel lands, its extremely annoying.
Tournaments are also unplayable.
River Belle is the same group, but they are not on the same server.
The Gaming Club is the same server as Jackpot City, and I have the same problems there, so it I think its a matter of too much traffic.
Support says it has to be my connection (high speed ADSL, yeah right)
So lets find another place to play..;)
 

chayton

aka LooHoo
webmeister
PABnonaccred
CAG
Joined
Jun 5, 2006
Location
Edmonton Canada
Exactly the same problems as you describe, its the main reason I hardly play there anymore, it used to be one of my favourites.
Tried last week with a small deposit after a month of not playing there, and nothing had changed.:mad:
As you say, it takes many seconds before the first reel lands, its extremely annoying.
Tournaments are also unplayable.
River Belle is the same group, but they are not on the same server.
The Gaming Club is the same server as Jackpot City, and I have the same problems there, so it I think its a matter of too much traffic.
Support says it has to be my connection (high speed ADSL, yeah right)
So lets find another place to play..;)
lol, at least there's no shortage of MG casinos to play at. Too bad about Jackpot City, I like playing there too, but it's bloody excrutiating with that lag - maybe I should move to Australia since it works from there...? :D
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top